requires the ionCube PHP Loader ioncube_loader错误

    网站 泡泡 1406次浏览 已收录 0个评论

    出现requires the ionCube PHP Loader ioncube_loader_lin_5.6.so to be installed by the website operator错误怎么解决?
    上面说的是没有安装ionCube,所以我们先来安装一下ionCube
    进入http://www.ioncube.com/loaders.php ,根据你的系统是32位还是64位下载适当的软件包
    32位ionCube

    cd /usr/local
    wget http://downloads3.ioncube.com/loader_downloads/ioncube_loaders_lin_x86.tar.gz
    tar zxvf ioncube_loaders_lin_x86.tar.gz
    

    64位ionCube

    cd /usr/local
    wget http://downloads3.ioncube.com/loader_downloads/ioncube_loaders_lin_x86-64.tar.gz
    tar zxvf ioncube_loaders_lin_x86-64.tar.gz
    

    配置ionCube
    修改php.ini 在文件尾部添加以下代码:

    [ionCube Loader]
    zend_extension="/usr/local/ioncube/ioncube_loader_lin_php的版本号.so"
    

    列如
    PHP5.1

    [ionCube Loader]
    zend_extension="/usr/local/ioncube/ioncube_loader_lin_5.1.so"
    

    PHP5.2

    [ionCube Loader]
    zend_extension="/usr/local/ioncube/ioncube_loader_lin_5.2.so"
    

    PHP5.3

    [ionCube Loader]
    zend_extension="/usr/local/ioncube/ioncube_loader_lin_5.3.so"
    

    PHP5.4

    [ionCube Loader]
    zend_extension="/usr/local/ioncube/ioncube_loader_lin_5.4.so"
    

    PHP5.5

    [ionCube Loader]
    zend_extension="/usr/local/ioncube/ioncube_loader_lin_5.5.so"
    

    PHP5.6

    [ionCube Loader]
    zend_extension="/usr/local/ioncube/ioncube_loader_lin_5.6.so"
    

    这里需要注意的是:如果有安装Zend Optimizer,安装ionCube会和Zend Optimizer可能发生冲突,须将Zend Optimizer的代码放在ionCube的后面。
    重启完毕后,可以使用phpinfo来验证。或者直接建立一个PHP文件,内容如下:

    <?php
    echo var_export(extension_loaded('ionCube Loader') ,true);
    ?>
    

    打开结果为“true”就说明开启成功了。


    喜欢 (0)
    发表我的评论
    取消评论
    表情 贴图 加粗 删除线 居中 斜体 签到

    Hi,您需要填写昵称和邮箱!

    • 昵称 (必填)
    • 邮箱 (必填)
    • 网址